Outage affecting the Federal Reserve ACH network

Incident Report for InTouch Receipting

Resolved

This incident has been resolved.
Posted Mar 03, 2026 - 16:52 PST

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Mar 03, 2026 - 14:42 PST

Identified

We have been notified of a delay impacting today’s settlement files for US merchant accounts due to a nationwide outage affecting the Federal Reserve ACH network.

This disruption is impacting ACH processing across all US banks and payment processors.

All InTouch transactions have been successfully captured, and all funds collected are secure. Settlement to your merchant account will occur as soon as the Federal Reserve ACH services are restored.

You can monitor the status of the Federal Reserve services here:
https://frbservices.org/app/status/serviceStatus.do (see “FedACH”)

We will continue to monitor the situation and provide updates as more information becomes available.
Posted Mar 03, 2026 - 10:39 PST