Error Banner in InTouch Pay

Incident Report for InTouch Receipting

Resolved

The Microsoft issue has been resolved, and we are not showing any issues.
Posted Jun 23, 2026 - 09:11 PDT

Update

We are working closely with Microsoft to find a resolution.
Thank you for your patience.
Posted Jun 22, 2026 - 08:27 PDT

Update

We are continuing to work closely with Microsoft on this issue and expect a resolution soon.
Posted Jun 19, 2026 - 10:01 PDT

Investigating

We are aware of the issue and are working closely with Microsoft to resolve the problem.
This error banner is affecting payments, devices, registrations, printing, and some payment pages.
Posted Jun 18, 2026 - 10:50 PDT
This incident affected: Card-Present Payments and Card-Not-Present Payments.