Intermittent issues with our Support Portal

Incident Report for InTouch Receipting

Resolved

This issue has been resolved. If you are still experiencing any issues, you may need to clear your browser cache and restart your session for the fixes to fully take effect.

If you continue to experience issues after doing so, please contact us at support@intouchpay.kevgroup.com
Posted Sep 16, 2026 - 07:24 PDT

Update

We are continuing to monitor for any further issues.
Posted Sep 16, 2026 - 07:23 PDT

Monitoring

We’re currently experiencing intermittent issues with our Support Portal due to disruptions affecting the platform that powers it. As a result, you may have difficulty accessing the Support Portal or submitting support cases through the webform.

While this issue is ongoing, we encourage you to submit support cases via email at support@intouchpay.kevgroup.com.

We will update the status page as soon as additional information becomes available.

We apologize for the inconvenience and appreciate your patience as we work through this issue.
Posted Sep 16, 2026 - 06:01 PDT